#6247
Mahesh Kurmi
Keymaster

Link updated … You must have JavaScript 7+ installed to run executable, which is just exe wrapper of runnable jar.
Kindly try simPHY app too, you will enjoy teaching with it.
Waiting for feedback..

  • This reply was modified 3 years, 9 months ago by Mahesh Kurmi.