File Menu

  • New: Creates new blank simulation
  • Open: Opens file browser ,now the folder where the project is saved. Double-click the ".ssim" file inside this folder to open the project.
  • Import: Differs from open because only objects and joints are imported, no script or setting are imported
  • Save as: Opens"Save as" dialog, enter a name for the new simulation into the " Name" entry field. Click the browse button next to the "Browse" entry field and choose a path for the new simulation in the file chooser.
  • Download: You can download simulations uploaded by users to our server by clicking over menu download simulations, where a window pops up.

The Snapshot Menu

A snapshot is a saved state of a simulation. Snapshots allow you to save the current state of the simulation without having to save it to a file. Snapshots are lost when you open a simulation, create a new simulation, or close the application.

Each time the simulation is started an automatic Snapshot is created. Automatic snapshots have the text (Automatic) appended to the date-time stamp. You can reload the state of the simulation before any Start by going to the Snapshots menu and clicking the respective  snapshot. You can also add your own snapshots by clicking the Take Snapshot menu item.

You can also clear all the stored snapshots by clicking the  Clear All Snapshots menu item.

The Simulation Menu

The Simulations menu item contains a number of pre-constructed simulations that are used to show SimPhy capabilities.

There are various categories in which example simulations are divided.

Click on menu to load simulations, modify the simulation and save it to your simulation directory.

The Window Menu

  • Preferences: Clicking preferences menu opens up preferences window.
  • Show/hide Tools: Click this menu to toggle visibility of toolbars.
  • Console Window: Click this menu to show/hide scripting console window.
  • Objects Table: Click this menu to show/hide simulation tree panel and object's properties panel.
  • Look and feel: Click this menu to change the complete appearance of application. By default this sis set to 'windows'

The Help Menu

All menu Items are self explainatory