The Playground

For getting started with SimPHY the best way is to go through getting started video.

Default window of SimPHY5.0 appears as below

1
2
3
1

Simulation Control Toolbar

Play, pause and run simulations in steps

2

Analyse toolbar

draw Forces, graphs, attach tracers and apply force on the body

3

Object Creation toolbar

Create bodies (disc blocks nd polygons) by simply drag and draw

It consists of elements which can be shown/hidden using menu>>window

  1. Main Menu: The main menu gives access to the functions of Help
  2. ToolBars: Each toolbar contains tools to create/analyze simulation objects
  3. Simulation Tree Panel: Shows list of created Objects, Joints , Forces and widgets which are there in the simulation
  4. Property Panel: Show some basic properties of joints and objects and allows quick editing of these properties.
  5. Status Bar: Displays Information regarding current actions and some tips for the tools.
  6. Canvas: Main Display of SimPhy where simulation is rendered (obviously it can not be hidden)

Simulation Panel

You can set bounds of world by right clicking Grid icon and clicking setBounds.

Just click on node element to select body or joint. The property table will automatically be updated as per selection.

You can get Pop up menu by right clicking the element in tree view to edit or remove the element. Although bodies, joints and widgets can be added/edited using mouse tools as well, but elements like Force/Torque and Rays can be edited or removed using popup menu only.

You can show/hide simulation panel using main menu Window>>Object table

You can also resize panel vertically by dragging Separator line or clicking small black triangles.

Properties Panel

You can set bounds of world by right clicking Grid icon and clicking setBounds.

Just click on node element to select body or joint. The property table will automatically be updated as per selection.

You can get Pop up menu by right clicking the element in tree view to edit or remove the element. Although bodies, joints and widgets can be added/edited using mouse tools as well, but elements like Force/Torque and Rays can be edited or removed using popup menu only.

You can show/hide simulation panel using main menu Window>>Object table

You can also resize panel vertically by dragging Separator line or clicking small black triangles.

Status Bar

Statusbar is the areas that convey status information about the application and environment. It displays

  1. current position of Mouse Cursor in world coordinates
  2. hints about current tool Selected
  3. various information's during interacting with bodies/joints